“Casi” todas mis extensiones funcionan a la perfección con la nueva versión de Firefox (muy diferente al caso de la actualización 1.5.0.1, que deshabilitó varias)… salvo por AI Roboform, un password manager…

Pero bueno, qué hacer en caso de que encuentren una extensión que no quiera funcionar luego de la actualización?

Evilsoft publicó, hace ya casi 2 meses, un buen tip para forzar a las extensiones a reconocer la nueva versión de Firefox, para que puedan funcionar. Así que aquí les traduzco una parte, paso a paso:

  • Cerrar Firefox, y abrir el archivo extensions.rdf (que se debe encontrar en C:Documents and Settingsnombre de usuarioApplication DataMozillaFirefoxProfilesdefault.ugt, con el Bloc de Notas. OJO: no abrirlo con Word o Wordpad, pues malogrará el archivo. OJO2: El folder Application Data puede estar oculto, así que tienen que mostrarlo, yendo a Herramientas| Opciones de Folder| Ver| Mostrar archivos y folders escondidos
  • Ahora, se debe buscar, dentro de todo el texto que aparece, una linea que diga NS1:maxVersion=”1.5” y modificarla por NS1:maxVersion=”1.6”
  • Abrimos firefox, nos dirigimos a las extensiones, right click en la deshabilitada, y la habilitamos.

Ahora, dudo mucho que tengan que hacer esto con la mayoría de extensiones, pues casi todas han cambiado su maxVersion a 1.6, a la hora de actualizarlas. Pero quizás encuentren una que otra que no quiere funcionar, y ahí es donde aplican lo que evilsoft recomienda…. Este tip no logró resolver mi problema con Roboform, sin embargo, así que a esperar nomás que lo actualicen