Picture 2

WordPress 2.8 acaba de salir del horno, y actualizarlo, es más simple que nunca!

Ya que la versión 2.7 trajo actualizaciones automáticas, basta con ir a “Herramientas / Actualizar” (o Settings / Upgrade):

Como lo hizo › Tablero — WordPress

Nota: Si están con WordPress en Español, todavía no verán la versión 2.8 como disponible. Supongo que estará lista en un par de días.

 

Una vez aquí (asegúrense de realizar un backup de la base de datos antes, por si acaso), le dan a “Upgrade Automatically” o “Actualizar Automáticamente”, esperan unos segundos, y listo! Estarán con la más reciente versión de WordPress 2.8. Acabo de instalarlo en varios blogs y hasta ahora, ningún problema.

 

Novedades

WordPress 2.8 no es tan revolucionario como WordPress 2.7 (que bien pudo llamarse 3.0), pero trae varias mejoras:

Mejorado el Panel de Widgets

Picture 3

Antes, configurar y mover Widgets en WordPress era un dolor de cabeza (salvando cambios por cada sidebar). Ahora, la interfaz ha sido renovada, y notarán que ya no hay un botón de save, además de la posibilidad de ver los múltiples sidebars que tengamos en la misma pantalla. Basta con arrastrar los Widgets de un lado a otro, para que los cambios queden salvados!

 

Navegador de Temas incluído

Buscando un nuevo tema para WordPress? Ahora pueden acceder al buscador de Temas, directamente desde WordPress! Basta con ir a Appearance / Add New Themes:

Picture 4

  • Cuatro Columnas en el Dashboard: Si tienen demasiadas cosas en el Dashboard, ahora podemos hacer uso de 4 columnas para reordenarlos
  • Soporte de Zonas Horarias: Un problema que tuve con WordPress 2.7 y 2.7.1 eran las zonas horarias (a veces programaba Posts que no aparecían a tiempo). Esto ha sido reparado en WordPress 2.8
  • Velocidad: Automatic nos dice que WordPress 2.8 es mucho más rápido, y por lo que he visto hasta ahora, tengo que creerles. Los paneles de administración se sienten más veloces.
  • Bugs, bugs bugs: Han sido corregidos alrededor de 790 bugs, así que de más está decir que es una versión recomendada para todos

Algo que no me gusta desde el 2.7, sin embargo, son los menús al lado izquierdo. Si bien al principio me pareció una buena idea, luego de meses de usar 2.7 y ahora 2.8, lo encuentro mucho más difícil y lento navegar entre los diferentes paneles de configuración de WordPress. Oh, bueno, hora de buscar un plugin que me permita ponerlos en la parte superior.

Y ustedes, ya actualizaron a WordPress 2.8? Por cierto, si encuentran algún problema con la página (arturogoga.com  después de la actualización, por favor notificarmelo en los comentarios!

  • Pues suena bien interesante! voy a actualizar mi blog para tener la ultima version, no me importa si esta en ingles.

  • Kse

    Yo también he notado una mejoría en el rendimiento en wordpress 2.8 solo me tomo unos minutos para actualizar y quedo muy bien ;).

  • Arturo, actualicé mi blog de la manera que tú lo hiciste y cuando trato de escribir un post no me sale la opción de publicar … ¿Cambió la manera en la que se publica o algo salió mal?

  • @chochi
    Algo debe haber salido mal :(. Si es así, tendrás que instalar la 2.8 de la manera tradicional, encima de los archivos que ya copiaste. No te botó algún mensaje de error durante la instalación?
    La manera “normal” de actualizar es simplemente bajarte el Zip File de WordPress 2.8, y sobre-escribir los archivos (teniendo cuidado de no borrar los que ya tienes en tu servidor de wp-config.php y las carpetas wp-content/themes, wp-content/plugins, wp-content/uploads)

  • @arturo: Arturo, ya lo pude solucionar. No me tiró ningún mensaje de error, volví a actualizar y seguía igual. Desactivé todos los plugins que tenía y ya funcionó. Así que supongo debe haber algunos plugins que causen conflicto con esta nueva versión y que desconfiguren el dashboard. Un saludo y gracias por la ayuda.

  • Acabo de actualizar mi blog a la version 2.8 y la verdad me he llevado sorpresas agradables y otras no tanto. Las agradables van por el lado de los widgets que son mucho mas configurables, amables en su manejo y con una mayor rapidez, lo malo es el bug o incompatibilidad que se viene arrastrando desde la version 2.5 con el editor TinyMCE que viene incorporado, sencillamente en la ultima version de wordpress vuelbe a aparecer este problema que segun me he informado se trata de un problema con la version de PHP que tenga el host … bueno si alguien sabe como solucionarlo por favor que postee aqui o en su efecto se contacte conmigo en mi blog.

    saludos.

    (por cierto muy buen blog arturo! )

  • disculpa no especifique el error en cuestion .. sencillamente la barra de edicion visual no aparece …. y los botones para agregar imagenes y video no cumplen su funcion o ejecutan acciones confusas que desconfiguran el formato del post.

    Ahora si .. saludos!

  • Actualicé sin errores.

  • Juan

    Gente he actualizado con el automatic upgrade a la 2.8
    Y perdi el Editor Visual.

    Desactivo todos los plugins y nada no aparece el Editor visual.
    Voy a la configuracion de mi usuario y esta habilitada el mismo.

    alguien tiene alguna sugerencia?
    gracias

  • RC

    Me pasa lo mismo que a Juan. He perdido todos los botones del editor visual. He activado plugins, he borrado cache, he hecho logout… de todo

    Ya no sé que hacer, necesito algo de ayudita.

  • Juan

    aqui una solucion temporal
    http://wordpress.org/extend/plugins/fckeditor-for-wordpress-plugin/screenshots/

    Un editor visual q hace una suerte de Word en el WP me parece miedio choto pero sirve para safar hasta nuevo aviso exitos

  • Yo tengo problemas con el editor de código, también decir que después de varios días sigue sin aparecer la versión en español

  • Tambien ya actualice mi blog y me agrada mucho el editor de temas 😀 . Por cierto comparto que deberia existir un plugin para poner los menus del lado izquierdo en la parte superior.

    Esperemos noticias de algun bugs en esta version, nunca faltan :D.

  • RC

    Conseguí reparar lo del editor visual, y ya vuelve a aparecer. Procedimiento por la fuerza bruta:
    1.-copia de seguridad de las carpetas wp-admin y wp-includes.
    2.-borrar carpetas wp-admin y wp-includes.
    3.-restauración de estas carpetas desde una copia de wordpress fresca de la misma version que nuestro blog.
    4.-comprobación.

    Espero que os sirva a los que habeis tenido el mismo problema que yo.

  • @RC
    Gracias por compartir tu solución :D. Yo estuve tratando de replicar el error en otros blogs sin éxito y quizás se deba a lo que explica @Folk3n30, es decir, incompatibilidad con versiones antiguas de php. Pero si tu solución es sólo reemplazar wp-admin / wp-includes (básicamente todo wordpress 2.8 :P) entonces genial!

    Aunque quizás se pueda conseguir sólo reemplazando la carpeta de tinymce?

  • Bueee, algunas veces hasta la solución mas absurda da resultados y en este caso la fuerza bruta o solucion “raw” al problema de los botones del editor visual de WordPress : “Funcionaron!!!!” … hize lo que explico RC y Arturo … solo copie nuevamente la carpeta TinyMCE al servidor, logueo a WP, creo un nuevo post y … Voila! ahy estan los botones!

    Gracias a todos .. a lo cavernicola tambien sirve 😀

  • Supremamente interesante lo rápido de la actualización automática! deja un sabor amargo creer que fueron cambios menores…

  • Juan

    Segui los pasos de borrar las carpetas y reinstalar en limpio y nada el editor Visual no levanta =(